A vulnerability has been identified in armeria versions 0.80.0 through 1.42.0, where attackers who control file names can cause stored…
- Exploited
- No known exploitation
- Fix
- Fixed in 1.43.0
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 1.43.0.
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.11% · 1st percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 2/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Armeria, a Java framework for building web services, is affected when directory listing is enabled: an attacker who can control file names can plant a script that runs in the browser of a user who views the listing, which is a stored cross-site scripting flaw. The attacker must already have local access and some low-level login, and the victim must take an action such as opening the listing.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
A vulnerability has been identified in armeria versions 0.80.0 through 1.42.0, where attackers who control file names can cause stored cross-site scripting (XSS) when directory listing is enabled and a user views the listing.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure?/25Unknown. No advisory context yet
- Reach?/20Unknown. No tracked technology or package matched
- Severity2.4/10CVSS 2.4
- No patch0/5No signal
What would change the score
- Would score about 57 if added to CISA KEV
- Would score about 52 if CISA's SSVC rates exploitation active
- Would score about 24 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 1.43.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- LY Corporation Armeria
From 0.80.0 · fixed in 1.43.0
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121822
Is CVE-2026-121822 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-121822?
Armeria: from 0.80.0 before 1.43.0.Source: cve.now feed data
How do I fix CVE-2026-121822?
Upgrade to a fixed version: 1.43.0.Source: cve.now feed data