Skip to main content
← Vulnerabilities

A vulnerability has been identified in armeria versions 0.84.0 through 1.42.0, where any-origin CORS policies do not enforce configured…

5.3MediumCNA
Exploited
No known exploitation
Fix
Fixed in 1.43.0
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 1.43.0.

Published
Last modified
0.32% · 25th percentile
12/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

The Armeria Java framework, in versions 0.84.0 through 1.42.0, does not enforce configured path restrictions on any-origin CORS policies. An attacker can lure a victim who is logged in to a malicious website, which can remotely, without logging in, read sensitive responses from the excluded paths when credentials are enabled and the victim's browser sends them.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

A vulnerability has been identified in armeria versions 0.84.0 through 1.42.0, where any-origin CORS policies do not enforce configured path restrictions, allowing an attacker-controlled website visited by an authenticated victim to read sensitive responses from excluded paths when credentials are enabled and the victim's browser sends authentication credentials.

cve.now Index

12Pcve.now Index 12 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure7/25Reachable over the network without a login · Unknown: No advisory context yet
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity5.3/10CVSS 5.3
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 27 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 1.43.0.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • LY Corporation Armeria

    From 0.84.0 · fixed in 1.43.0

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-121821

Is CVE-2026-121821 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-121821?

Armeria: from 0.84.0 before 1.43.0.Source: cve.now feed data

How do I fix CVE-2026-121821?

Upgrade to a fixed version: 1.43.0.Source: cve.now feed data