Skip to main content
← Vulnerabilities

A vulnerability has been identified in armeria-saml prior to 1.41.1, where bearer assertions are not enforced for one-time use, allowing…

Armeria-saml before 1.41.1 does not enforce one-time use of bearer SAML assertions, so a valid signed SAML Response can be replayed within its validity window. Fixed in 1.41.1.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.6HighCNA
Exploited
No known exploitation
Fix
Fixed in 1.41.1
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Armeria-saml versions before 1.41.1

20Pcve.now Index 20 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.6/10CVSS 7.6
  • No patch0/5No signal

What would change the score

  • Would score about 70 if added to CISA KEV
  • Would score about 65 if CISA's SSVC rates exploitation active

CVE-2026-11749 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.6 (high) and affects Armeria; fixed in 1.41.1.

Published
Last modified
Published
Not listed in CISA KEV
0.27% · 19th percentile
20/100 · provisional
Specific setups only
Fix
Fixed in 1.41.1
None on Exploit-DB, Metasploit or GitHub

Summary

A vulnerability has been identified in armeria-saml prior to 1.41.1, where bearer assertions are not enforced for one-time use, allowing replay of previously consumed assertion IDs within their validity period.

What to do

  • Check whether your setup matches what the bug needs.

    Armeria-saml versions before 1.41.1
  • Upgrade to a fixed version: 1.41.1.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated

Affected versions

  • LY Corporation Armeria

    Version range not reported

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-11749

Is CVE-2026-11749 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Armeria-saml does not enforce one-time use of bearer SAML assertions. A valid signed SAML Response can be replayed within its validity window to create multiple authenticated sessions without a new identity provider login.Source: line.github.io, github.com

Am I affected, and how do I check?

The advisory covers armeria-saml versions before 1.41.1. To check a version, look at the armeria-saml dependency version in the project's build file.Source: line.github.io, github.com

How do I fix CVE-2026-11749?

Update armeria-saml to 1.41.1 or later, as the advisory recommends.Source: line.github.io, github.com