Skip to main content
← Vulnerabilities

A vulnerability has been identified in armeria-xds versions 1.40.0 through 1.42.0, where DataSourcePolicy checks filename containment…

5.9MediumCNA
Exploited
No known exploitation
Fix
Fixed in 1.43.0
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 1.43.0.

Published
Last modified
0.33% · 25th percentile
9/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

The armeria-xds library has a flaw that lets an attacker with high privileges, reached remotely over the network, such as a compromised or semi-trusted xDS control plane, make the xDS client read files outside its allowed root directories through a symbolic link inside an allowed directory. In deployments that use a credential injector, header-compatible text secrets may also be exposed to an attacker-observable upstream.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

A vulnerability has been identified in armeria-xds versions 1.40.0 through 1.42.0, where DataSourcePolicy checks filename containment without resolving symbolic links, allowing a compromised or semi-trusted xDS control plane to cause the xDS client to read files outside configured allowed root directories when a symbolic link inside an allowed directory points outside it. In deployments using a credential injector, header-compatible text secrets may be exposed to an attacker-observable upstream.

cve.now Index

9Pcve.now Index 9 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure3/25Reachable over the network · Unknown: No advisory context yet
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity5.9/10CVSS 5.9
  • No patch0/5No signal

What would change the score

  • Would score about 64 if added to CISA KEV
  • Would score about 59 if CISA's SSVC rates exploitation active
  • Would score about 28 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 1.43.0.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • LY Corporation Armeria

    From 1.40 · fixed in 1.43.0

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-121819

Is CVE-2026-121819 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-121819?

Armeria: from 1.40 before 1.43.0.Source: cve.now feed data

How do I fix CVE-2026-121819?

Upgrade to a fixed version: 1.43.0.Source: cve.now feed data