A vulnerability has been identified in armeria-saml versions prior to 1.43.0, where the HTTP-Redirect binding decoder decompresses…
Affects armeria-saml 1.42.0 and earlier, in SAML service providers built without specified endpoints, which register the HTTP-Redirect binding by default. Fixed in 1.43.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 1.43.0
- Who is exposed
- Default setups
Do first: Check every install: default setups are affected.
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.40% · 34th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 31/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Default setups
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The armeria-saml library, before version 1.43.0, is affected through its HTTP-Redirect binding decoder, which decompresses attacker-supplied SAML messages without capping the output size before signature checks. An attacker can reach it remotely without logging in and exhaust server memory, causing a denial of service.
Read the original description
A vulnerability has been identified in armeria-saml versions prior to 1.43.0, where the HTTP-Redirect binding decoder decompresses attacker-supplied SAML messages without limiting the output size before signature validation, allowing an unauthenticated remote attacker to exhaust server memory and cause a denial of service.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure22/25Default setups, reachable over the network without a login
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
What to do
Check every install: default setups are affected.
Upgrade to a fixed version: 1.43.0.
Workaround: Lower maxRequestLength on the SAML endpoints and/or front them with a proxy/WAF that caps request body size, until upgrading. Alternatively, disable the HTTP-Redirect binding and use HTTP-POST only.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- LY Corporation Armeria
Version range not reported
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121820
Is CVE-2026-121820 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The HTTP-Redirect binding decoder decompresses request data in a way that lets an unauthenticated client force the server to allocate large amounts of heap memory. At small heap sizes this causes an OutOfMemoryError and denial of service. Confidentiality and integrity are not affected.Source: github.com
Am I affected, and how do I check?
Versions of armeria-saml up to and including 1.42.0 are affected. The HTTP-Redirect binding endpoints are registered by default when the SAML service provider is built without specified endpoints, so check the armeria-saml version in the project's dependencies and whether the SamlServiceProviderBuilder setup specifies endpoints.Source: github.com
How do I fix CVE-2026-121820?
Upgrade armeria-saml to 1.43.0 or later, which contains the fix.Source: github.com