A vulnerability has been identified in armeria versions prior to 1.43.0, where processing malformed Thrift messages can cause excessive…
Affects armeria-thrift 1.42.0 and earlier, including 0.9-0.24 variants. Fixed in armeria-thrift 1.43.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 1.43.0
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 1.43.0.
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.41% · 35th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Armeria library is affected by a flaw in how it processes malformed Thrift messages, which can cause excessive memory allocation. A remote attacker can exploit this without logging in to cause a denial of service.
Read the original description
A vulnerability has been identified in armeria versions prior to 1.43.0, where processing malformed Thrift messages can cause excessive memory allocation, potentially resulting in denial of service.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 1.43.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- LY Corporation Armeria
From 1.43.0
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121824
Is CVE-2026-121824 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Malformed Thrift messages in small requests can make Armeria allocate excessive heap memory. This can exhaust memory or cause heavy garbage collection, leading to denial of service.Source: line.github.io, github.com
Which versions are affected by CVE-2026-121824?
Armeria: from 1.43.0.Source: cve.now feed data
Am I affected, and how do I check?
Armeria versions before 1.43.0 are affected through the armeria-thrift module, including armeria-thrift 0.9-0.24 variants. With libthrift 0.14 and newer, the transport availability check is disabled, and with libthrift 0.14 through 0.23 the field length limit is also bypassed. Check the armeria-thrift version in the project's dependency file or build output, and the libthrift version in use.Source: line.github.io, github.com
How do I fix CVE-2026-121824?
Update armeria-thrift to version 1.43.0 or later.Source: line.github.io, github.com