A vulnerability has been identified in armeria versions prior to 1.43.0, where inconsistent request path normalization can allow…
Only servers that protect a path prefix with a decorator in front of FileService, TomcatService or JettyService are affected, in Armeria versions before 1.43.0. The fix is in 1.43.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 1.43.0
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 1.43.0.
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.44% · 38th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A vulnerability has been identified in armeria versions prior to 1.43.0, where inconsistent request path normalization can allow unauthenticated attackers to bypass path-based access controls and access protected resources.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 1.43.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- LY Corporation Armeria
Version range not reported
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-121823
Is CVE-2026-121823 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Inconsistent request path normalization can let unauthenticated requests get past path-based access controls and reach files or resources under a protected path.Source: github.com, line.github.io
Am I affected, and how do I check?
Armeria versions before 1.43.0 (up to 1.42.0) are affected when a decorator protects a path prefix in front of FileService, TomcatService or JettyService. The issue was reproduced with FileService on every minor line from 1.13 to 1.42.0. To check, look at the Armeria version in the build dependency file and whether a path-prefix decorator sits in front of one of these services.Source: github.com, line.github.io
How do I fix CVE-2026-121823?
Update Armeria to 1.43.0 or later, as the advisory recommends. No workaround is listed.Source: github.com, line.github.io