WordPress Superb Addons: Blocks, Patterns & theme Designer plugin <= 4.2.4 - Cross Site Request Forgery (CSRF) vulnerability
Superb Addons: Blocks, Patterns & Theme Designer plugin 4.2.4 and earlier is affected. The fix is in version 4.2.5.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.2.5
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Superb Addons plugin version 4.2.4 or earlier
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.13% · 2nd percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 24/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
The Superb Addons: Blocks, Patterns & Theme Designer WordPress plugin has a cross-site request forgery (CSRF) flaw that lets an attacker trick a logged-in user into performing unintended actions on the site. An attacker can reach it remotely, without logging in, but only if a user is lured into visiting a malicious page or clicking a crafted link.
Read the original description
Cross-Site Request Forgery (CSRF) vulnerability in Suplugins Superb Addons: Blocks, Patterns & Theme Designer superb-blocks allows Cross Site Request Forgery.This issue affects Superb Addons: Blocks, Patterns & Theme Designer: from n/a through 4.2.4.
cve.now Index
- Exploitation0/40No signal
- Exposure15/25Specific setups only, CISA rates it automatable
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.8/10CVSS 8.8
- No patch0/5No signal
What would change the score
- Would score about 74 if added to CISA KEV
- Would score about 69 if CISA's SSVC rates exploitation active
What to do
Check whether your setup matches what the bug needs.
Superb Addons plugin version 4.2.4 or earlierUpgrade to a fixed version: 4.2.5.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- superb-blocks
through 4.2.4
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-66669
Is CVE-2026-66669 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A cross-site request forgery flaw lets an attacker trick logged-in users into performing actions they did not intend, such as changing passwords or making purchases.Source: patchstack.com, cve.org
Which versions are affected by CVE-2026-66669?
superb-blocks: through 4.2.4.Source: cve.now feed data
Am I affected, and how do I check?
Versions 4.2.4 and earlier of the Superb Addons: Blocks, Patterns & Theme Designer plugin by Suplugins are affected. To check a site, look at the plugin version shown on the WordPress Plugins screen.Source: patchstack.com, cve.org
How do I fix CVE-2026-66669?
Update the plugin to version 4.2.5 or later.Source: patchstack.com, cve.org