Skip to main content
← Vulnerabilities

WordPress PowerPress Podcasting plugin <= 11.18.0 - Cross Site Request Forgery (CSRF) vulnerability

Affects the PowerPress Podcasting plugin for WordPress, versions 11.18.0 and earlier. The fix is in 11.18.2 or later.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.8HighCNA
Exploited
No known exploitation
Fix
Fixed in 11.18.2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. PowerPress Podcasting plugin version 11.18.0 or earlier (vulnerable versions <= 11.18.0)

Published
Last modified
0.20% · 9th percentile
22/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

The WordPress PowerPress Podcasting plugin has a cross-site request forgery flaw. An attacker can lure a logged-in user into triggering unwanted actions on the site, and the vulnerability can be reached remotely without logging in, but it requires the victim to take an action such as visiting a malicious page.

Read the original description

Cross-Site Request Forgery (CSRF) vulnerability in Blubrry Podcasting PowerPress Podcasting powerpress allows Cross Site Request Forgery.This issue affects PowerPress Podcasting: from n/a through 11.18.0.

cve.now Index

22Pcve.now Index 22 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.8/10CVSS 8.8, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 72 if added to CISA KEV
  • Would score about 67 if CISA's SSVC rates exploitation active

What to do

  • Check whether your setup matches what the bug needs.

    PowerPress Podcasting plugin version 11.18.0 or earlier (vulnerable versions <= 11.18.0)
  • Upgrade to a fixed version: 11.18.2.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • powerpress

    through 11.18.0

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-121762

Is CVE-2026-121762 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A cross-site request forgery flaw lets a malicious page trick a logged-in user into performing actions they did not intend, such as changing passwords or making purchases.Source: patchstack.com, cve.org

Which versions are affected by CVE-2026-121762?

powerpress: through 11.18.0.Source: cve.now feed data

Am I affected, and how do I check?

The PowerPress Podcasting plugin for WordPress, version 11.18.0 and earlier, is affected. The installed version is listed on the WordPress Plugins screen.Source: patchstack.com, cve.org

How do I fix CVE-2026-121762?

Update the PowerPress Podcasting plugin to version 11.18.2 or the latest available version.Source: patchstack.com, cve.org