OpenEMR: CSRF Protection Bypass on IPPF Point-of-Sale Void and Regen Operations
OpenEMR versions before 8.3.0 are affected when a logged-in staff member, such as a billing clerk or admin, visits an attacker-controlled page. Fixed in 8.3.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 8.3.0
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. OpenEMR versions before 8.3.0 are affected. The victim is an authenticated staff member, such as a billing clerk or admin, whose browser visits an attacker-controlled page.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 19/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
OpenEMR, an open source electronic health records and medical practice management application, is affected by a cross-site request forgery flaw in its point-of-sale checkout page for IPPF billing. An attacker can remotely, without logging in, trick an authenticated billing user into voiding checkouts or regenerating invoice counters, which can alter ledger state, financial reports, and audit records, provided the victim is lured into taking an action such as opening a malicious page.
Read the original description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to 8.3.0, interface/patient_file/pos_checkout_ippf.php performs state-changing void, voidall, and regen operations through GET requests without CSRF token validation. The form_checksum integrity check is conditional and is skipped when the parameter is omitted, allowing a cross-site request to force an authenticated billing user to void checkouts or regenerate invoice counters. The resulting changes can alter ledger state, financial reporting, and audit records. This issue is fixed in version 8.3.0.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure12/25Specific setups only, reachable over the network without a login
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.1/10CVSS 7.1
- No patch0/5No signal
What would change the score
- Would score about 69 if added to CISA KEV
- Would score about 64 if CISA's SSVC rates exploitation active
What to do
Check whether your setup matches what the bug needs.
OpenEMR versions before 8.3.0 are affected. The victim is an authenticated staff member, such as a billing clerk or admin, whose browser visits an attacker-controlled page.Upgrade to a fixed version: 8.3.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- openemr openemr
fixed in 8.3.0
Evidence 4
- Advisory
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-103938
Is CVE-2026-103938 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A page controlled by an outside attacker can cause a logged-in staff browser to void legitimate point-of-sale checkouts or regenerate transaction invoice counters without the staff member noticing. This changes ledger, financial reporting and audit records.Source: github.com
Which versions are affected by CVE-2026-103938?
openemr: before 8.3.0.Source: cve.now feed data
Am I affected, and how do I check?
OpenEMR versions before 8.3.0 are in scope. Check the installed OpenEMR version to see whether it falls before 8.3.0; the exposure also requires a logged-in staff session visiting an attacker-controlled page.Source: github.com
How do I fix CVE-2026-103938?
Upgrade OpenEMR to 8.3.0 or later, which contains the fix.Source: github.com