OpenAM 14.5.1 before 16.1.4 CSRF in OAuth 2.0 Device Flow
Only affects OpenAM 14.5.1 through 16.1.3 where the OAuth 2.0 provider allows clients to skip consent and the client uses implied consent. Fixed in OpenAM 16.1.4.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 16.1.4
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. The OAuth 2.0 provider allows clients to skip consent (off by default). The client is configured with implied consent. Affected OpenAM versions are 14.5.1 up to and including 16.1.3.
- Published
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 19/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
OpenAM from 14.5.1 before 16.1.4 contains a cross-site request forgery vulnerability in the OAuth 2.0 device authorization flow that allows attackers to approve device codes when consent is skipped for implied-consent clients. Attackers can start a device authorization and lure a logged-in user to a crafted page, obtaining access and ID tokens to call APIs as that user.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure12/25Specific setups only, reachable over the network without a login
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.1/10CVSS 7.1
- No patch0/5No signal
What would change the score
- Would score about 69 if added to CISA KEV
- Would score about 64 if CISA's SSVC rates exploitation active
What to do
Check whether your setup matches what the bug needs.
The OAuth 2.0 provider allows clients to skip consent (off by default). The client is configured with implied consent. Affected OpenAM versions are 14.5.1 up to and including 16.1.3.Upgrade to a fixed version: 16.1.4.
Workaround: Turn off "Allow clients to skip consent" in the OAuth 2.0 provider settings of every realm that does not need it.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- OpenIdentityPlatform OpenAM
From 14.5.1 · fixed in 16.1.4
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-123545
Is CVE-2026-123545 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A cross-site request forgery flaw in the OAuth 2.0 Device Flow lets an attacker obtain access and ID tokens for a user who is logged in to OpenAM. The attacker can then read that user's profile claims and call APIs available under the granted scopes, acting as that user.Source: github.com
Which versions are affected by CVE-2026-123545?
OpenAM: from 14.5.1 before 16.1.4.Source: cve.now feed data
Am I affected, and how do I check?
Affected versions are OpenAM 14.5.1 up to and including 16.1.3. The issue applies only where the OAuth 2.0 provider allows clients to skip consent, an option that is off by default, and the client is configured with implied consent. Checking means confirming the OpenAM version and the "Allow clients to skip consent" setting in each realm's OAuth 2.0 provider settings, along with each client's consent configuration.Source: github.com
How do I fix CVE-2026-123545?
Upgrade to OpenAM 16.1.4, which contains the fix.Source: github.com