Skip to main content
← Vulnerabilities

OpenAM 14.0.0 before 16.1.4 Session Token Disclosure via Notification WebSocket

Affects OpenAM 14.0.0 through 16.1.3 when agent notifications are enabled, which is the default. Fixed in 16.1.4.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

10.0CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 16.1.4
Who is exposed
Default setups

Do first: Check every install: default setups are affected.

Published
Last modified
32/100 · provisional
Default setups
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

OpenAM from 14.0.0 before 16.1.4 contains an information disclosure vulnerability that allows unauthenticated attackers to read live session tokens from the notification WebSocket. Attackers can bypass the agent-only check through an unvalidated internal forward on legacy Liberty ID-FF endpoints, collecting iPlanetDirectoryPro tokens to hijack user and administrator sessions.

cve.now Index

32Pcve.now Index 32 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure22/25Default setups, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity10/10CVSS 10.0
  • No patch0/5No signal

What would change the score

  • Would score about 72 if added to CISA KEV
  • Would score about 67 if CISA's SSVC rates exploitation active

What to do

  • Check every install: default setups are affected.

  • Upgrade to a fixed version: 16.1.4.

  • Workaround: Restrict network access to /openam/notifications and /openam/ws/* at the reverse proxy, load balancer or firewall, allowing only the agent hosts that legitimately consume the notification WebSocket

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • OpenIdentityPlatform OpenAM

    From 14.0.0 · fixed in 16.1.4

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123551

Is CVE-2026-123551 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The notification WebSocket can leak live session tokens to an unauthenticated party. Each leaked token lets the holder act as that user until the session ends, including administrator sessions, which can lead to configuration takeover and command execution on the server.Source: github.com

Which versions are affected by CVE-2026-123551?

OpenAM: from 14.0.0 before 16.1.4.Source: cve.now feed data

Am I affected, and how do I check?

OpenAM versions 14.0.0 up to and including 16.1.3 are affected when agent notifications are enabled, which is the default. Check the installed OpenAM version and whether agent notifications are enabled in the server configuration.Source: github.com

How do I fix CVE-2026-123551?

Upgrade OpenAM to version 16.1.4, which contains the fix.Source: github.com