Skip to main content
← Vulnerabilities

OpenAM before 16.1.4 Unauthenticated DoS via Unbounded Java Deserialisation

Affects OpenAM releases up to and including 16.1.3 that expose endpoints accepting serialized Java data. Fixed in 16.1.4.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 16.1.4
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 16.1.4.

Published
Last modified
26/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub

Summary

OpenAM before 16.1.4 contains a denial of service vulnerability that allows unauthenticated attackers to exhaust server resources by sending serialized Java data without size or structure limits. Attackers can send small crafted requests to remote SDK endpoints, classic login pages, or the administration console to block authentication, session validation and policy decisions.

cve.now Index

26Pcve.now Index 26 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.7/10CVSS 8.7
  • No patch0/5No signal

What would change the score

  • Would score about 71 if added to CISA KEV
  • Would score about 66 if CISA's SSVC rates exploitation active
  • Would score about 31 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 16.1.4.

  • Workaround: Restrict network access to the legacy remote SDK endpoints at the reverse proxy or firewall, restrict the administration console to administrators' networks, and limit request size and rate

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • OpenIdentityPlatform OpenAM

    fixed in 16.1.4

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123543

Is CVE-2026-123543 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Several OpenAM endpoints accept serialized Java data from requests, and unbounded deserialization lets a few small unauthenticated requests exhaust the server's CPU or memory. This can block authentication, session validation and policy decisions.Source: github.com

Which versions are affected by CVE-2026-123543?

OpenAM: before 16.1.4.Source: cve.now feed data

Am I affected, and how do I check?

All OpenAM releases up to and including 16.1.3 are affected where reachable endpoints accept serialized Java data: remote SDK interfaces, classic login pages, or the administration console. To check, look at the installed OpenAM version and whether those endpoints are enabled and reachable.Source: github.com

How do I fix CVE-2026-123543?

Upgrade to OpenAM 16.1.4, which contains the fix.Source: github.com