Skip to main content
← Vulnerabilities

OpenAM before 16.1.4 SAML 1.x Signature Verification Issuer Impersonation

Only affects OpenAM up to and including 16.1.3 when SAML 1.x is used with more than one trusted partner or with other parties' certificates in the keystore. Fixed in 16.1.4.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.5HighCNA
Exploited
No known exploitation
Fix
Fixed in 16.1.4
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Deployment uses SAML 1.x with more than one trusted partner, or keeps certificates of other parties in OpenAM's keystore OpenAM release up to and including 16.1.3

Published
Last modified
16/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

OpenAM before 16.1.4 does not verify that a signed SAML 1.x assertion or response was signed by the partner named as its issuer, accepting a signature from any certificate in OpenAM's keystore. An attacker holding such a private key, such as a trusted SAML 1.x partner, can forge assertions claiming another partner's issuer and sign in as that partner's users, including privileged ones.

cve.now Index

16Pcve.now Index 16 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.5/10CVSS 7.5
  • No patch0/5No signal

What would change the score

  • Would score about 66 if added to CISA KEV
  • Would score about 61 if CISA's SSVC rates exploitation active
  • Would score about 23 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Deployment uses SAML 1.x with more than one trusted partner, or keeps certificates of other parties in OpenAM's keystore OpenAM release up to and including 16.1.3
  • Upgrade to a fixed version: 16.1.4.

  • Workaround: Remove SAML 1.x trusted partners and block the SAML 1.x endpoints at the reverse proxy if SAML 1.x is not in use

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • OpenIdentityPlatform OpenAM

    fixed in 16.1.4

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123538

Is CVE-2026-123538 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A holder of a trusted partner certificate's private key can sign SAML 1.x assertions that claim to come from a different partner. This lets the attacker sign in as that partner's users, including privileged ones.Source: github.com

Which versions are affected by CVE-2026-123538?

OpenAM: before 16.1.4.Source: cve.now feed data

Am I affected, and how do I check?

All OpenAM releases up to and including 16.1.3 are in scope, but only deployments that use SAML 1.x with more than one trusted partner or that keep other parties' certificates in OpenAM's keystore are affected. To check, confirm the installed release version and review the SAML 1.x trusted partner setup and keystore contents.Source: github.com

How do I fix CVE-2026-123538?

Upgrade to OpenAM 16.1.4, which contains the fix.Source: github.com