OpenAM before 16.1.4 PKCE Bypass in OAuth 2.0 Device Authorization Flow
Affects OpenAM releases up to and including 16.1.3 that provide the OAuth 2.0 device flow. Fixed in 16.1.4.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 16.1.4
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. OpenAM releases up to and including 16.1.3 that provide the OAuth 2.0 device flow The device code was requested with a PKCE challenge
- Published
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 20/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
OpenAM before 16.1.4 fails to enforce PKCE in the OAuth 2.0 device authorization flow, never validating the code verifier when device codes are exchanged for tokens. Attackers who obtain an approved device code from client logs or shared device storage can redeem it for access and ID tokens to impersonate the user.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure12/25Specific setups only, reachable over the network without a login
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.6/10CVSS 7.6
- No patch0/5No signal
What would change the score
- Would score about 70 if added to CISA KEV
- Would score about 65 if CISA's SSVC rates exploitation active
What to do
Check whether your setup matches what the bug needs.
OpenAM releases up to and including 16.1.3 that provide the OAuth 2.0 device flow The device code was requested with a PKCE challengeUpgrade to a fixed version: 16.1.4.
Workaround: Allow the device code grant only for clients that need it, and where possible use confidential clients that authenticate to the token endpoint.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- OpenIdentityPlatform OpenAM
fixed in 16.1.4
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-123542
Is CVE-2026-123542 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
An attacker can exchange an approved device code for an access token and an ID token, then act as the user toward APIs that accept those tokens.Source: github.com
Which versions are affected by CVE-2026-123542?
OpenAM: before 16.1.4.Source: cve.now feed data
Am I affected, and how do I check?
All OpenAM releases up to and including 16.1.3 that provide the OAuth 2.0 device flow are in scope. Clients that send no PKCE challenge are not affected, so the device code must have been requested with a PKCE challenge. A reader can check the installed OpenAM release against 16.1.4 and whether the device authorization flow is enabled.Source: github.com
How do I fix CVE-2026-123542?
Upgrade OpenAM to 16.1.4, the fixed version.Source: github.com