Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

7.5HighCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 12.1.1.3.

Published
Last modified
0.39% · 33rd percentile
28/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow an authenticated attacker to send unauthorized requests from the system due to server-side request forgery. This could be used to enumerate network resources or to support further attacks.

cve.now Index

28Pcve.now Index 28 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure20/25No login or user action needed, CISA rates it automatable · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.5/10CVSS 7.5
  • No patch0/5No signal

What would change the score

  • Would score about 73 if added to CISA KEV
  • Would score about 68 if CISA's SSVC rates exploitation active
  • Would score about 33 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now1 day
  3. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  4. Record last updated

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-19128

Is CVE-2026-19128 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaw is a server-side request forgery bug. An authenticated attacker can make the system send unauthorized requests, which could be used to enumerate network resources or support further attacks.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-19128?

API Connect: from 12.1.0.0 through 12.1.1.2.Source: cve.now feed data

Am I affected, and how do I check?

Versions of IBM API Connect from 12.1.0.0 through 12.1.1.2 are affected. To check, look up the installed API Connect version in your deployment. No specific configuration is listed as a condition.Source: ibm.com, cve.org

How do I fix CVE-2026-19128?

Upgrade to IBM API Connect 12.1.1.3, which contains the fix. No workaround is listed in the facts.Source: ibm.com, cve.org

Why do the sources disagree?

The description says the attacker must be authenticated, but the CVSS vector records that no privileges are required (PR:N). The score follows the vector, while the impact text follows the description.Source: ibm.com, cve.org