Skip to main content
← Vulnerabilities

IBM API Connect Denial of Service

9.6CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 10.0.8.13
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affects the Analytics component (analytics-v2-director) in the v10.0.8 release stream

Published
Last modified
0.29% · 21st percentile
18/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

IBM API Connect is affected by a denial-of-service flaw, caused by regular expression processing and improper handling of wildcard query operators. An attacker with low-privilege credentials can exploit it remotely over the network, and no user action is needed.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 are vulnerable to a Regular Expression Denial of Service (ReDoS) attack and to improper neutralisation of wildcard query operators.

cve.now Index

18Pcve.now Index 18 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.6/10CVSS 9.6
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 25 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Affects the Analytics component (analytics-v2-director) in the v10.0.8 release stream
  • Upgrade to a fixed version: 10.0.8.13.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2; From 10.0.8.0 · through 10.0.8.12

Evidence 2

  1. Patch
  2. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-18535

Is CVE-2026-18535 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The Analytics component of IBM API Connect can be pushed into a Regular Expression Denial of Service (ReDoS) condition, where a crafted input makes regex processing consume excessive resources and slow or stop the service. The result is a denial of service.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-18535?

API Connect: from 12.1.0.0 through 12.1.1.2; from 10.0.8.0 through 10.0.8.12.Source: cve.now feed data

Am I affected, and how do I check?

The advisory covers IBM API Connect in the 12.1.0.0 through 12.1.1.2 range and the 10.0.8.0 through 10.0.8.12 range, but the Analytics component (analytics-v2-director) is the part named as vulnerable in the v10.0.8 release stream. To check, look at the API Connect version in your installation and confirm whether the Analytics component is deployed.Source: ibm.com, cve.org

How do I fix CVE-2026-18535?

IBM strongly recommends upgrading to 10.0.8.13. No workaround is listed in the facts.Source: ibm.com, cve.org