Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

8.5HighCNA
Exploited
No known exploitation
Fix
Fixed in 10.0.8.13
Who is exposed
Specific setups only

Do first: Upgrade to a fixed version: 10.0.8.13.

Published
Last modified
0.36% · 29th percentile
17/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

IBM API Connect is affected by multiple vulnerabilities, including a server-side request forgery flaw that lets a remote attacker with low-privilege login obtain sensitive information. The attacker can reach it over the network, and no user action is needed.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

IBM API Connect 10.0.8.0 through 10.0.8.12 could allow a remote authenticated attacker to obtain sensitive information due to a server-side request forgery vulnerability.

cve.now Index

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.5/10CVSS 8.5
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

What to do

  • Upgrade to a fixed version: 10.0.8.13.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM API Connect

    From 10.0.8.0 · through 10.0.8.12

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17384

Is CVE-2026-17384 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A remote attacker who has a valid login can make the server send requests on their behalf, which can expose sensitive information. This is a server-side request forgery flaw.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17384?

API Connect: from 10.0.8.0 through 10.0.8.12.Source: cve.now feed data

Am I affected, and how do I check?

IBM API Connect versions from 10.0.8.0 through 10.0.8.12 are listed as affected. To check your version, look at the product version shown in the API Connect management console or its installed build information.Source: ibm.com, cve.org

How do I fix CVE-2026-17384?

IBM strongly recommends upgrading to API Connect 10.0.8.13, which contains the fix.Source: ibm.com, cve.org