Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

9.8CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 12.1.1.3.

Published
Last modified
0.93% · 60th percentile
27/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to execute arbitrary code due to improper neutralization of special elements in an OS command.

cve.now Index

27Pcve.now Index 27 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.8/10CVSS 9.8
  • No patch0/5No signal

What would change the score

  • Would score about 72 if added to CISA KEV
  • Would score about 67 if CISA's SSVC rates exploitation active
  • Would score about 32 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2; From 10.0.8.0 · through 10.0.8.12

Evidence 2

  1. Patch
  2. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17408

Is CVE-2026-17408 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaw is an improper neutralization of special elements in an OS command, which could allow a remote attacker to execute arbitrary code.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17408?

API Connect: from 12.1.0.0 through 12.1.1.2; from 10.0.8.0 through 10.0.8.12.Source: cve.now feed data

Am I affected, and how do I check?

Versions 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12 of IBM API Connect are listed as affected. Check the installed API Connect version to compare it against these ranges.Source: ibm.com, cve.org

How do I fix CVE-2026-17408?

IBM strongly recommends upgrading to v12.1.1.3 now. The fix listed in the facts is 12.1.1.3, and no fixed release for the 10.0.8 range is listed.Source: ibm.com, cve.org