Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

7.4HighCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 12.1.1.3.

Published
Last modified
0.34% · 27th percentile
24/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub

Summary

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to bypass authentication and assign arbitrary roles due to improper verification of cryptographic signatures.

cve.now Index

24Pcve.now Index 24 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.4/10CVSS 7.4
  • No patch0/5No signal

What would change the score

  • Would score about 69 if added to CISA KEV
  • Would score about 64 if CISA's SSVC rates exploitation active
  • Would score about 29 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2; From 10.0.8.0 · through 10.0.8.12

Evidence 2

  1. Patch
  2. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17379

Is CVE-2026-17379 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaw can let a remote attacker bypass authentication and assign arbitrary roles to themselves.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17379?

API Connect: from 12.1.0.0 through 12.1.1.2; from 10.0.8.0 through 10.0.8.12.Source: cve.now feed data

Am I affected, and how do I check?

Affected ranges are IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12. Compare the installed version against these ranges.Source: ibm.com, cve.org

How do I fix CVE-2026-17379?

IBM strongly recommends upgrading to v12.1.1.3 now. The sources do not list a fixed version for the 10.0.8 branch.Source: ibm.com, cve.org