Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 12.1.1.3.

Published
Last modified
0.31% · 24th percentile
26/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub

Summary

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a local attacker to obtain sensitive information due to the use of a hard-coded cryptographic key.

cve.now Index

26Pcve.now Index 26 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.7/10CVSS 8.7
  • No patch0/5No signal

What would change the score

  • Would score about 71 if added to CISA KEV
  • Would score about 66 if CISA's SSVC rates exploitation active
  • Would score about 31 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17356

Is CVE-2026-17356 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaw could allow an attacker to obtain sensitive information from IBM API Connect. The advisory describes the attacker as a local one.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17356?

API Connect: from 12.1.0.0 through 12.1.1.2.Source: cve.now feed data

Am I affected, and how do I check?

IBM API Connect versions 12.1.0.0 through 12.1.1.2 are in the affected range. To check an installed version, look at the API Connect version shown in its administration or version information.Source: ibm.com, cve.org

How do I fix CVE-2026-17356?

IBM strongly recommends upgrading to v12.1.1.3 now. No workaround is listed in the facts.Source: ibm.com, cve.org

Why do the sources disagree?

The vulnerability description says a local attacker is needed, but the CVSS vector lists the attack vector as network (AV:N). The sources do not reconcile this difference.Source: ibm.com, cve.org