Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

8.2HighCNA
Exploited
No known exploitation
Fix
Fixed in v12.1.1.3
Who is exposed
Specific setups only

Do first: Upgrade to a fixed version: v12.1.1.3.

Published
Last modified
0.37% · 30th percentile
16/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information from internal network resources due to server-side request forgery. Destination checks on outbound requests can be bypassed, which could allow the server to reach internal systems that should be blocked.

cve.now Index

16Pcve.now Index 16 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.2/10CVSS 8.2
  • No patch0/5No signal

What would change the score

  • Would score about 66 if added to CISA KEV
  • Would score about 61 if CISA's SSVC rates exploitation active
  • Would score about 23 if CISA's SSVC rates it automatable

What to do

  • Upgrade to a fixed version: v12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17355

Is CVE-2026-17355 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Server-side request forgery makes the server send requests to internal systems that should be blocked, which can expose sensitive information from internal network resources.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17355?

API Connect: from 12.1.0.0 through 12.1.1.2.Source: cve.now feed data

Am I affected, and how do I check?

IBM API Connect versions 12.1.0.0 through 12.1.1.2 are listed as affected, and no specific configuration conditions are given. To check, compare the installed API Connect version against that range.Source: ibm.com, cve.org

How do I fix CVE-2026-17355?

Upgrade to v12.1.1.3, which IBM strongly recommends doing now.Source: ibm.com, cve.org