Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

8.5HighCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Specific setups only

Do first: Upgrade to a fixed version: 12.1.1.3.

Published
Last modified
0.36% · 29th percentile
17/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to server-side request forgery.

cve.now Index

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.5/10CVSS 8.5
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

What to do

  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17352

Is CVE-2026-17352 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaw is a server-side request forgery, which can let an attacker make the server send requests on their behalf and so obtain sensitive information. The sources describe the impact only at this level.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17352?

API Connect: from 12.1.0.0 through 12.1.1.2.Source: cve.now feed data

Am I affected, and how do I check?

IBM API Connect versions from 12.1.0.0 up to and including 12.1.1.2 are listed as affected. To check a version, look at the product's version information in its admin or command interface and compare it with that range.Source: ibm.com, cve.org

How do I fix CVE-2026-17352?

IBM strongly recommends upgrading to version 12.1.1.3, which is the fixed release listed in the advisory.Source: ibm.com, cve.org