Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

9.3CriticalCNA
Exploited
No known exploitation
Fix
Fixed in v12.1.1.3
Who is exposed
Not reported

Do first: Upgrade to a fixed version: v12.1.1.3.

Published
Last modified
0.51% · 43rd percentile
26/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information due to server-side request forgery. A service that can be reached without authentication could be made to send requests to unintended destinations.

cve.now Index

26Pcve.now Index 26 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.3/10CVSS 9.3
  • No patch0/5No signal

What would change the score

  • Would score about 71 if added to CISA KEV
  • Would score about 66 if CISA's SSVC rates exploitation active
  • Would score about 31 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: v12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17344

Is CVE-2026-17344 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The bug is a server-side request forgery flaw: a remote attacker can make the server send requests to destinations the operator did not intend, which can expose sensitive information.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17344?

API Connect: from 12.1.0.0 through 12.1.1.2.Source: cve.now feed data

Am I affected, and how do I check?

IBM API Connect versions from 12.1.0.0 through 12.1.1.2 are listed as affected. To check a deployment, look up the installed API Connect version and compare it against that range.Source: ibm.com, cve.org

How do I fix CVE-2026-17344?

IBM strongly recommends upgrading to v12.1.1.3, which is the fixed version listed in the advisory.Source: ibm.com, cve.org