Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

8.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Specific setups only

Do first: Upgrade to a fixed version: 12.1.1.3.

Published
Last modified
0.45% · 39th percentile
16/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass authorization checks to access or modify sensitive information due to improper authorization.

cve.now Index

16Pcve.now Index 16 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.1/10CVSS 8.1
  • No patch0/5No signal

What would change the score

  • Would score about 66 if added to CISA KEV
  • Would score about 61 if CISA's SSVC rates exploitation active
  • Would score about 23 if CISA's SSVC rates it automatable

What to do

  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17343

Is CVE-2026-17343 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

An authenticated remote attacker can bypass authorization checks in IBM API Connect to access or modify sensitive information. The flaw is in the access control checks, so a logged-in user can reach data that should be restricted.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17343?

API Connect: from 12.1.0.0 through 12.1.1.2.Source: cve.now feed data

Am I affected, and how do I check?

The advisory lists IBM API Connect from 12.1.0.0 up to and including 12.1.1.2. No specific configuration is listed as a condition, so the version is the main thing to check. Compare your installed version against that range to see whether it falls within it.Source: ibm.com, cve.org

How do I fix CVE-2026-17343?

Upgrade to IBM API Connect 12.1.1.3, which is the fixed version named in the advisory.Source: ibm.com, cve.org