Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

7.2HighCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 12.1.1.3.

Published
Last modified
0.32% · 25th percentile
24/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub

Summary

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to perform server-side request forgery and relay unauthorized email messages due to improper neutralization of user-supplied input.

cve.now Index

24Pcve.now Index 24 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.2/10CVSS 7.2
  • No patch0/5No signal

What would change the score

  • Would score about 69 if added to CISA KEV
  • Would score about 64 if CISA's SSVC rates exploitation active
  • Would score about 29 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17341

Is CVE-2026-17341 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A remote attacker can make the server send requests it should not send, which is server-side request forgery, and can relay unauthorized email messages through it.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17341?

API Connect: from 12.1.0.0 through 12.1.1.2.Source: cve.now feed data

Am I affected, and how do I check?

The listed range is IBM API Connect 12.1.0.0 through 12.1.1.2. The sources do not list any extra configuration conditions, so check the installed API Connect version against that range.Source: ibm.com, cve.org

How do I fix CVE-2026-17341?

Upgrade to IBM API Connect 12.1.1.3, which IBM says fixes this. IBM strongly recommends addressing the vulnerability now by upgrading.Source: ibm.com, cve.org