Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Specific setups only

Do first: Upgrade to a fixed version: 12.1.1.3.

Published
Last modified
0.41% · 35th percentile
15/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to modify application API subscriptions due to broken object-level authorization.

cve.now Index

15Pcve.now Index 15 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 65 if added to CISA KEV
  • Would score about 60 if CISA's SSVC rates exploitation active
  • Would score about 22 if CISA's SSVC rates it automatable

What to do

  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17311

Is CVE-2026-17311 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

An authenticated remote attacker can change application API subscriptions they should not be able to modify, because of broken object-level authorization. The access check does not stop a logged-in user from acting on objects that belong to others.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17311?

API Connect: from 12.1.0.0 through 12.1.1.2.Source: cve.now feed data

Am I affected, and how do I check?

IBM API Connect from 12.1.0.0 through 12.1.1.2 is affected. To check your version, look at the API Connect version shown in its admin console or product information, and confirm it falls within that range.Source: ibm.com, cve.org

How do I fix CVE-2026-17311?

Upgrade API Connect to v12.1.1.3, which IBM's advisory says fixes this issue.Source: ibm.com, cve.org