Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

8.0HighCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 12.1.1.3.

Published
Last modified
0.15% · 3rd percentile
8/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub

Summary

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information and tamper with configuration due to improper certificate validation.

cve.now Index

8Pcve.now Index 8 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure?/25Unknown. Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8/10CVSS 8.0
  • No patch0/5No signal

What would change the score

  • Would score about 63 if added to CISA KEV
  • Would score about 58 if CISA's SSVC rates exploitation active
  • Would score about 30 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17309

Is CVE-2026-17309 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaws can be used to obtain sensitive information and to tamper with configuration in IBM API Connect. The advisory covers multiple vulnerabilities under this CVE.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17309?

API Connect: from 12.1.0.0 through 12.1.1.2.Source: cve.now feed data

Am I affected, and how do I check?

Versions of IBM API Connect from 12.1.0.0 through 12.1.1.2 are listed as affected, with no particular setup conditions given. To check a installation, compare its API Connect version against that range.Source: ibm.com, cve.org

How do I fix CVE-2026-17309?

Upgrade IBM API Connect to version 12.1.1.3, which the vendor names as the fix.Source: ibm.com, cve.org