Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

Affects IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12. IBM's listed fix is version 12.1.1.3.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.6CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Submitted definitions with externally referenced content are processed without sufficient restriction on those references

Published
Last modified
0.44% · 38th percentile
18/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to perform arbitrary file reads and server-side request forgery due to unrestricted resolution of external references. Externally referenced content in submitted definitions is not sufficiently restricted when processed, and the retrieved content could be returned to the attacker.

cve.now Index

18Pcve.now Index 18 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.6/10CVSS 9.6
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 25 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Submitted definitions with externally referenced content are processed without sufficient restriction on those references
  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2; From 10.0.8.0 · through 10.0.8.12

Evidence 2

  1. Patch
  2. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17299

Is CVE-2026-17299 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Submitted definitions that contain externally referenced content are not sufficiently restricted when processed. An attacker can perform arbitrary file reads and server-side request forgery, and the retrieved content could be returned to the attacker.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17299?

API Connect: from 12.1.0.0 through 12.1.1.2; from 10.0.8.0 through 10.0.8.12.Source: cve.now feed data

Am I affected, and how do I check?

The affected ranges are IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12. Compare the installed API Connect version against these ranges.Source: ibm.com, cve.org

How do I fix CVE-2026-17299?

IBM strongly recommends upgrading to v12.1.1.3 now. The checked facts list no fixed version for the 10.0.8 range.Source: ibm.com, cve.org