Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

Affects IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12 during sign-in. The only listed fix is 12.1.1.3 for the 12.1 line.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.6CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. The vulnerable redirect is used during the sign-in flow

Published
Last modified
0.61% · 49th percentile
22/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to perform an account takeover due to an open redirect vulnerability. The redirect address used during sign-in is not sufficiently validated, which could allow authentication results to be sent to an attacker-controlled location.

cve.now Index

22Pcve.now Index 22 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.6/10CVSS 9.6
  • No patch0/5No signal

What would change the score

  • Would score about 72 if added to CISA KEV
  • Would score about 67 if CISA's SSVC rates exploitation active

What to do

  • Check whether your setup matches what the bug needs.

    The vulnerable redirect is used during the sign-in flow
  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2; From 10.0.8.0 · through 10.0.8.12

Evidence 2

  1. Patch
  2. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17297

Is CVE-2026-17297 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The sign-in redirect address is not sufficiently validated, so authentication results could be sent to an attacker-controlled location. The advisory describes the impact as account takeover.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17297?

API Connect: from 12.1.0.0 through 12.1.1.2; from 10.0.8.0 through 10.0.8.12.Source: cve.now feed data

Am I affected, and how do I check?

The listed affected ranges are API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12. The vulnerable redirect is used in the sign-in flow, so check the installed API Connect version against these ranges and whether sign-in is configured in that flow.Source: ibm.com, cve.org

How do I fix CVE-2026-17297?

IBM strongly recommends upgrading to v12.1.1.3. The facts list no fixed version for the 10.0.8 line, so check IBM's advisory for that line's fix status.Source: ibm.com, cve.org