Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

Affects IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12 when schemas are validated. IBM's fix is in 12.1.1.3.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Schema validation is performed on submitted content

Published
Last modified
0.44% · 38th percentile
16/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper validation of external references. When schemas are validated, references to external resources are not sufficiently restricted, which could allow the server to retrieve content it should not access.

cve.now Index

16Pcve.now Index 16 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.7/10CVSS 7.7
  • No patch0/5No signal

What would change the score

  • Would score about 66 if added to CISA KEV
  • Would score about 61 if CISA's SSVC rates exploitation active
  • Would score about 23 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Schema validation is performed on submitted content
  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now1 day
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2; From 10.0.8.0 · through 10.0.8.12

Evidence 2

  1. Patch
  2. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17285

Is CVE-2026-17285 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

When schemas are validated, the server does not sufficiently restrict references to external resources, so it can retrieve content it should not access, which can expose sensitive information.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17285?

API Connect: from 12.1.0.0 through 12.1.1.2; from 10.0.8.0 through 10.0.8.12.Source: cve.now feed data

Am I affected, and how do I check?

The affected ranges are IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12. The issue applies only where schema validation is performed on submitted content. Compare the installed version with these ranges.Source: ibm.com, cve.org

How do I fix CVE-2026-17285?

IBM strongly recommends upgrading to 12.1.1.3 now. The checked facts do not name a fixed version for the 10.0.8 branch.Source: ibm.com, cve.org