Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

Affects IBM API Connect versions 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12, where provider-supplied HTML is shown to users. The fix is in 12.1.1.3.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Provider-supplied HTML content is displayed to users without sufficient sanitization

Published
Last modified
0.44% · 38th percentile
17/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary JavaScript due to cross-site scripting. HTML content supplied by a provider is not sufficiently sanitized before it is displayed, which could allow script content to run in the user's browser.

cve.now Index

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.7/10CVSS 8.7
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Provider-supplied HTML content is displayed to users without sufficient sanitization
  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2; From 10.0.8.0 · through 10.0.8.12

Evidence 2

  1. Patch
  2. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-17190

Is CVE-2026-17190 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Provider-supplied HTML content is not sufficiently sanitized before it is displayed, which could allow script content to run in the user's browser (cross-site scripting).Source: ibm.com, cve.org

Which versions are affected by CVE-2026-17190?

API Connect: from 12.1.0.0 through 12.1.1.2; from 10.0.8.0 through 10.0.8.12.Source: cve.now feed data

Am I affected, and how do I check?

The listed ranges are IBM API Connect 12.1.0.0 through 12.1.1.2 and 10.0.8.0 through 10.0.8.12. To check, compare the installed product version against these ranges.Source: ibm.com, cve.org

How do I fix CVE-2026-17190?

IBM strongly recommends upgrading to v12.1.1.3. The checked facts do not list a fixed version for the 10.0.8 line.Source: ibm.com, cve.org