Skip to main content
← Vulnerabilities

Multiple Vulnerabilities in IBM API Connect

9.9CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 12.1.1.3
Who is exposed
Specific setups only

Do first: Upgrade to a fixed version: 12.1.1.3.

Published
Last modified
0.53% · 44th percentile
18/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to bypass security restrictions due to a confused deputy vulnerability.

cve.now Index

18Pcve.now Index 18 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.9/10CVSS 9.9
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 25 if CISA's SSVC rates it automatable

What to do

  • Upgrade to a fixed version: 12.1.1.3.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • IBM API Connect

    From 12.1.0.0 · through 12.1.1.2

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-16920

Is CVE-2026-16920 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A remote attacker who already has an authenticated login can bypass security restrictions. The cause is a confused deputy flaw, where a component with more privileges can be misused to act on behalf of a requester who lacks them.Source: ibm.com, cve.org

Which versions are affected by CVE-2026-16920?

API Connect: from 12.1.0.0 through 12.1.1.2.Source: cve.now feed data

Am I affected, and how do I check?

IBM API Connect from 12.1.0.0 through 12.1.1.2 is affected. To check, look up the installed API Connect version and see whether it falls in that range. The facts list no additional setup conditions.Source: ibm.com, cve.org

How do I fix CVE-2026-16920?

Upgrade to API Connect 12.1.1.3, which is the fixed version named by IBM. IBM strongly recommends upgrading now, and no workaround is listed.Source: ibm.com, cve.org