Devalue before 5.6.3 Denial of Service via Sparse Array Serialization
Affects devalue before 5.6.3 when sparse arrays are serialized with uneval or stringify. The fix is in 5.6.3.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 5.6.3
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 5.6.3.
- Published
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The devalue package for npm before 5.6.3 can consume excessive CPU and memory when serializing sparse arrays with uneval or stringify. An attacker who manages to get a sparse array created on the server, which mainstream wire formats do not allow, and serialized there can cause a denial of service.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 5.6.3.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- sveltejs devalue
fixed in 5.6.3
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-123569
Is CVE-2026-123569 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Serializing a sparse array with devalue's uneval or stringify can use excessive CPU and memory, which can cause a denial of service on the server.Source: vulncheck.com, github.com
Which versions are affected by CVE-2026-123569?
devalue: before 5.6.3.Source: cve.now feed data
Am I affected, and how do I check?
devalue versions before 5.6.3 are affected when sparse arrays are serialized with uneval or stringify. A sparse array must be created on the server, which mainstream wire formats do not allow. To check, look up the installed devalue version in package.json or the lockfile, or run npm ls devalue.Source: vulncheck.com, github.com
How do I fix CVE-2026-123569?
Upgrade the devalue package to 5.6.3 or later.Source: vulncheck.com, github.com