Devalue before 5.9.3 CPU Amplification Denial of Service via uneval
Affects devalue 5.9.2 and earlier when an application passes attacker-influenced sparse values to uneval. Fixed in 5.9.3.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 5.9.3
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 5.9.3.
- Published
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Sveltejs devalue before 5.9.3 contains a denial of service vulnerability that allows attackers to cause CPU amplification by supplying sparse arrays to uneval. Attackers who influence sparse values passed to uneval can force synchronous work proportional to the declared array length, blocking the event loop.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 5.9.3.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- sveltejs devalue
fixed in 5.9.3
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-123566
Is CVE-2026-123566 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Attackers who influence sparse values passed to uneval can force synchronous CPU work proportional to the declared array length. That work blocks the event loop.Source: vulncheck.com, github.com
Which versions are affected by CVE-2026-123566?
devalue: before 5.9.3.Source: cve.now feed data
Am I affected, and how do I check?
Versions before 5.9.3 (affected versions are 5.9.2 and earlier) are affected, and only when an application passes attacker-influenced sparse values to uneval. To check, look at the devalue version your project installs, for example in its lockfile or package.json.Source: vulncheck.com, github.com
How do I fix CVE-2026-123566?
Upgrade devalue to 5.9.3 or later.Source: vulncheck.com, github.com