Devalue before 5.9.3 Typed-Array Allocation Validation Bypass via parse
Only affects devalue before 5.9.3 when a malformed custom ArrayBuffer reviver is used with parse. Fixed in 5.9.3.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 5.9.3
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Requires a malformed custom ArrayBuffer reviver in use with parse
- Published
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 21/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Devalue before 5.9.3 contains a validation bypass vulnerability that allows custom ArrayBuffer revivers to skip typed-array allocation checks in the parse function. Attackers can supply very small crafted input processed by a malformed ArrayBuffer reviver to allocate massive ArrayBuffers, causing memory exhaustion and denial of service.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure12/25Specific setups only, reachable over the network without a login
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
What to do
Check whether your setup matches what the bug needs.
Requires a malformed custom ArrayBuffer reviver in use with parseUpgrade to a fixed version: 5.9.3.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- sveltejs devalue
fixed in 5.9.3
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-123563
Is CVE-2026-123563 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Very small crafted input can make parse allocate massive ArrayBuffers, which exhausts memory and causes denial of service.Source: github.com, vulncheck.com
Which versions are affected by CVE-2026-123563?
devalue: before 5.9.3.Source: cve.now feed data
Am I affected, and how do I check?
Devalue versions before 5.9.3 are affected, but only when a malformed custom ArrayBuffer reviver is used with parse. To check, look at the installed devalue version (for example with npm ls devalue) and see whether code passes a custom ArrayBuffer reviver to parse.Source: github.com, vulncheck.com
How do I fix CVE-2026-123563?
Upgrade devalue to 5.9.3 or later, which is the listed fixed version. No workaround is listed in the checked facts.Source: github.com, vulncheck.com