Skip to main content
← Vulnerabilities

Sveltejs devalue before 5.9.3 Memory Exhaustion via uneval Sparse Arrays

Affects devalue from 1.0.0 before 5.9.3 when very large sparse arrays are serialized with uneval and the output is evaluated. Fixed in 5.9.3.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 5.9.3
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affects devalue from 1.0.0 before 5.9.3 The application serializes very large sparse arrays with uneval and the output is then evaluated

Published
Last modified
21/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

Sveltejs devalue from 1.0.0 before 5.9.3 contains a memory exhaustion flaw in uneval, whose generated code for sparse arrays allocates memory proportional to the array's declared length when evaluated. Attackers who can influence a very large sparse array serialized by an application can exhaust memory in the browser or runtime evaluating the output.

cve.now Index

21Pcve.now Index 21 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.7/10CVSS 8.7
  • No patch0/5No signal

What would change the score

  • Would score about 71 if added to CISA KEV
  • Would score about 66 if CISA's SSVC rates exploitation active

What to do

  • Check whether your setup matches what the bug needs.

    Affects devalue from 1.0.0 before 5.9.3 The application serializes very large sparse arrays with uneval and the output is then evaluated
  • Upgrade to a fixed version: 5.9.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • sveltejs devalue

    From 1.0.0 · fixed in 5.9.3

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123564

Is CVE-2026-123564 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A tiny serialized value can make a consuming browser or runtime allocate a large amount of memory, exhausting it.Source: vulncheck.com, github.com

Which versions are affected by CVE-2026-123564?

devalue: from 1.0.0 before 5.9.3.Source: cve.now feed data

Am I affected, and how do I check?

devalue versions from 1.0.0 before 5.9.3 contain the flaw in uneval. The advisory describes the risky setup as serializing very large sparse arrays with uneval and then evaluating the results. The installed devalue version can be checked in the project's package.json or lockfile.Source: vulncheck.com, github.com

How do I fix CVE-2026-123564?

Upgrade devalue to 5.9.3 or later.Source: vulncheck.com, github.com