Skip to main content
← Vulnerabilities

Ground Station 0.6.0 before 0.8.20 Credential Disclosure via get-orbital-sources

Ground Station 0.6.0 before 0.8.20 exposes stored orbital source usernames, passwords, and tokens to operator-role accounts through get-orbital-sources. Fixed in 0.8.20.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
Proof of concept public, per CISA
Fix
Fixed in 0.8.20
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Ground Station version 0.6.0 up to but not before 0.8.20 (affecting ground-station >= 0.6.0, < 0.8.20). An operator-role account exists, created during first-run setup. An administrator has saved a basic or token orbital source, so credentials are stored.

Published
Last modified
30/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

Ground Station software lets an attacker who is logged in remotely with a low-privilege operator account retrieve the plaintext usernames, passwords, and tokens that administrators stored for basic and token orbital sources. The flaw is in the get-orbital-sources and get-tle-sources handlers, which are not restricted to administrators even though the related write handlers are.

Read the original description

Ground Station from 0.6.0 before 0.8.20 does not restrict the get-orbital-sources Socket.IO handler (also exposed as get-tle-sources) to administrators, although the orbital-source write handlers are admin-only. An authenticated operator-role user can call either handler to retrieve the plaintext usernames, passwords, and tokens that administrators stored for basic and token orbital sources.

cve.now Index

30Pcve.now Index 30 of 100 · methodology v3 · provisional
  • Exploitation15/40CISA rates a proof of concept as public
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 65 if added to CISA KEV
  • Would score about 60 if CISA's SSVC rates exploitation active
  • Would score about 37 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Ground Station version 0.6.0 up to but not before 0.8.20 (affecting ground-station >= 0.6.0, < 0.8.20). An operator-role account exists, created during first-run setup. An administrator has saved a basic or token orbital source, so credentials are stored.
  • Upgrade to a fixed version: 0.8.20.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • sgoudelis ground-station

    From 0.6.0 · fixed in 0.8.20

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123485

Is CVE-2026-123485 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

An authenticated operator-role user can read the plaintext usernames, passwords, and tokens that administrators stored for basic and token orbital sources, using get-orbital-sources.Source: vulncheck.com, github.com

Which versions are affected by CVE-2026-123485?

ground-station: from 0.6.0 before 0.8.20.Source: cve.now feed data

Am I affected, and how do I check?

Ground Station versions from 0.6.0 up to but not before 0.8.20 are affected. Credentials are only exposed if an administrator has saved a basic or token orbital source, and operator-role accounts are created during first-run setup. Check the installed ground-station version against that range, and check whether any basic or token orbital source has been saved.Source: vulncheck.com, github.com

How do I fix CVE-2026-123485?

Upgrade Ground Station to version 0.8.20 or later, which is the listed fixed version.Source: vulncheck.com, github.com