Skip to main content
← Vulnerabilities

Moodle: missing access checks on h5p content files

Affects Moodle H5P content handling in 4.5.0 to before 4.5.15, 5.0.0 to before 5.0.11, 5.1.0 to before 5.1.8, and 5.2.0 to before 5.2.4. Fixed in the matching release for each branch.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.5HighCNA
Exploited
No known exploitation
Fix
Fixed in 4.5.15, 5.0.11, 5.1.8, 5.2.4
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 4.5.15, 5.0.11, 5.1.8, 5.2.4.

Published
Last modified
28/100 · provisional
Unclear
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Moodle, the open-source learning platform, has a flaw in how it checks access to H5P content files, letting anyone on the network view restricted materials, including files from hidden or unavailable course modules, without logging in. The attacker can read this protected content, but the flaw does not allow changes to data or disruption of the service.

Read the original description

A flaw was found in Moodle. Insufficient access control checks on H5P content files allow unauthenticated remote attackers to view restricted materials, including content stored in the system context and files belonging to hidden or unavailable course modules. This issue results in unauthorized information disclosure of protected content.

cve.now Index

28Pcve.now Index 28 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure20/25No login or user action needed, CISA rates it automatable · Unknown: Advisories don't say whether default setups are affected
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.5/10CVSS 7.5
  • No patch0/5No signal

What would change the score

  • Would score about 73 if added to CISA KEV
  • Would score about 68 if CISA's SSVC rates exploitation active
  • Would score about 33 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 4.5.15, 5.0.11, 5.1.8, 5.2.4.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  4. Record last updated

Affected versions

  • moodle

    From 4.5.0 · fixed in 4.5.15; From 5.0.0 · fixed in 5.0.11; From 5.1.0 · fixed in 5.1.8; From 5.2.0 · fixed in 5.2.4

Evidence 4

  1. Report
  2. Repository
  3. Link
  4. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123655

Is CVE-2026-123655 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Missing access checks let unauthenticated remote users view H5P content files that should be restricted. This includes content in the system context and files from hidden or unavailable course modules.Source: bugzilla.redhat.com, access.redhat.com

Which versions are affected by CVE-2026-123655?

moodle: from 4.5.0 before 4.5.15; from 5.0.0 before 5.0.11; from 5.1.0 before 5.1.8; from 5.2.0 before 5.2.4.Source: cve.now feed data

Am I affected, and how do I check?

Moodle versions 4.5.0 to before 4.5.15, 5.0.0 to before 5.0.11, 5.1.0 to before 5.1.8, and 5.2.0 to before 5.2.4 are in the affected ranges. Check the installed Moodle version against these ranges.Source: bugzilla.redhat.com, access.redhat.com

How do I fix CVE-2026-123655?

Upgrade to the fixed release for the installed branch: 4.5.15, 5.0.11, 5.1.8, or 5.2.4.Source: bugzilla.redhat.com, access.redhat.com