WordPress Upsell Order Bump Offer for WooCommerce plugin <= 3.1.6 - Broken Access Control vulnerability
- Exploited
- No known exploitation
- Fix
- Fixed in 3.1.7
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. WordPress Upsell Order Bump Offer for WooCommerce plugin version 3.1.6 or earlier
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 15/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The Upsell Order Bump Offer for WooCommerce WordPress plugin has a broken access control flaw that lets an attacker change data they should not be able to modify. It can be reached remotely by a user who has a low-privilege account, and no user interaction is needed.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
Missing Authorization vulnerability in WP Swings Upsell Order Bump Offer for WooCommerce upsell-order-bump-offer-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Upsell Order Bump Offer for WooCommerce: from n/a through 3.1.6.
cve.now Index
- Exploitation0/40No signal
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.1/10CVSS 7.1
- No patch0/5No signal
What would change the score
- Would score about 65 if added to CISA KEV
- Would score about 60 if CISA's SSVC rates exploitation active
- Would score about 22 if CISA's SSVC rates it automatable
What to do
Check whether your setup matches what the bug needs.
WordPress Upsell Order Bump Offer for WooCommerce plugin version 3.1.6 or earlierUpgrade to a fixed version: 3.1.7.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- upsell-order-bump-offer-for-woocommerce
through 3.1.6
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-115431
Is CVE-2026-115431 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The plugin fails to check whether a user is allowed to reach certain pages or actions, so a user can reach things they should not be able to. The advisory gives viewing other people's data as an example of this kind of access.Source: patchstack.com
Which versions are affected by CVE-2026-115431?
upsell-order-bump-offer-for-woocommerce: through 3.1.6.Source: cve.now feed data
Am I affected, and how do I check?
Versions 3.1.6 and earlier of the Upsell Order Bump Offer for WooCommerce plugin by WP Swings are affected. To check, open the plugin list in the WordPress admin and read the version shown beside Upsell Order Bump Offer for WooCommerce.Source: patchstack.com
How do I fix CVE-2026-115431?
Update the plugin to version 3.1.7 or later, which the advisory says resolves the vulnerability.Source: patchstack.com