fast-agent: `fast-agent serve` binds HTTP to 0.0.0.0 with no authentication by default; with --shell this is unauthenticated remote…
- Exploited
- No known exploitation
- Fix
- Fixed in 0.7.21
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 0.7.21.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 9/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
fast-agent serve can be reached remotely over the network. When it is started with --shell, an attacker can run operating-system commands as the server user, and without --shell, they can use the operator's model and configured MCP tools.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
fast-agent is a framework for building, running, and evaluating AI agents with Model Context Protocol support. Prior to 0.7.21, fast-agent serve uses HTTP transport bound to 0.0.0.0 on port 8000 without authentication, allowing any network client that can reach the /mcp endpoint to invoke the exposed agent tool. When the server is started with --shell, the agent can call the local execute tool implemented by tools/local_shell_executor.py, so an unauthenticated remote client can cause operating-system commands to run as the server user; without --shell, the client can still consume the operator's model and configured MCP tools. The defaults are defined in cli/commands/serve.py and mcp/server/agent_server.py, and the non-interactive server permission prompt does not prevent the described access. This issue is fixed in version 0.7.21.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure3/25Reachable over the network · Unknown: No advisory context yet
- Reach?/20Unknown. No tracked technology or package matched
- Severity6.4/10CVSS 6.4
- No patch0/5No signal
What would change the score
- Would score about 64 if added to CISA KEV
- Would score about 59 if CISA's SSVC rates exploitation active
- Would score about 28 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 0.7.21.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- evalstate fast-agent
fixed in 0.7.21
Evidence 4
- Advisory
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-102610
Is CVE-2026-102610 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-102610?
fast-agent: before 0.7.21.Source: cve.now feed data
How do I fix CVE-2026-102610?
Upgrade to a fixed version: 0.7.21.Source: cve.now feed data