ChatWiki before 2.10.0 Unauthenticated Document Disclosure via getLibRawFileOnePage
Affects ChatWiki versions before 2.10.0, where the GET /manage/getLibRawFileOnePage route is registered with no authentication middleware. The fix is in 2.10.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.10.0
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 2.10.0.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
ChatWiki before 2.10.0 contains a missing authentication vulnerability in the GET /manage/getLibRawFileOnePage route that allows unauthenticated attackers to read other tenants' documents. Attackers can enumerate sequential admin_user_id and file id query parameters, bypassing the ownership check, to retrieve PDF-rendered pages of any tenant's knowledge-base documents.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 2.10.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- zhimaAi chatwiki
fixed in 2.10.0
Evidence 6
- Patch
- Report
- Repository
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-124027
Is CVE-2026-124027 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The GET /manage/getLibRawFileOnePage route has no authentication check, so a request without logging in can read the content of knowledge-base documents, including PDF-rendered pages, by changing the admin_user_id and id query parameters.Source: vulncheck.com, github.com
Which versions are affected by CVE-2026-124027?
chatwiki: before 2.10.0.Source: cve.now feed data
Am I affected, and how do I check?
ChatWiki versions before 2.10.0 are in the affected range. To check, compare the installed ChatWiki version with 2.10.0; anything lower falls in the range described by the advisory.Source: vulncheck.com, github.com
How do I fix CVE-2026-124027?
Upgrade ChatWiki to version 2.10.0, which is the fixed release named in the advisory.Source: vulncheck.com, github.com