Skyline DataMiner BrokerGateway Embedded API Key Authentication Bypass
- Exploited
- No known exploitation
- Fix
- Fixed in 10.6.9 CU1, 10.6.0 CU7, 10.5.0 CU19, 10.4.0 CU22
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 10.6.9 CU1, 10.6.0 CU7, 10.5.0 CU19, 10.4.0 CU22.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Skyline DataMiner BrokerGateway contains an embedded API key flaw that lets an unauthenticated attacker over the network, without logging in, retrieve the installation-specific BrokerGateway key, even when pairing mode is disabled. The attacker can then use that key to obtain an unrestricted NATS credential and gain trusted message-bus access over TCP port 4222, without any prior DataMiner credentials.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
Skyline DataMiner BrokerGateway contains an embedded API key vulnerability that allows unauthenticated attackers to retrieve the installation-specific BrokerGateway key even while pairing mode is disabled. Attackers can use the retrieved key to obtain the unrestricted DataMinerUser.creds NATS credential and gain trusted message-bus access via TCP port 4222 without any prior DataMiner credentials. Fixed in DataMiner 10.6.9 CU1, 10.6.0 CU7, 10.5.0 CU19, and 10.4.0 CU22.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 10.6.9 CU1, 10.6.0 CU7, 10.5.0 CU19, 10.4.0 CU22.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- Skyline Communications DataMiner
From 10.6.9 · fixed in 10.6.9 CU1; From 10.6.0 · fixed in 10.6.0 CU7; From 10.5.0 · fixed in 10.5.0 CU19; From 10.4.0 · fixed in 10.4.0 CU22
Evidence 2
- Patch
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-89017
Is CVE-2026-89017 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The BrokerGateway embedded API key can be retrieved without prior DataMiner credentials. With that key, an attacker can obtain the unrestricted DataMinerUser.creds NATS credential and gain trusted access to the message bus on TCP port 4222.Source: vulncheck.com
Which versions are affected by CVE-2026-89017?
DataMiner: from 10.6.9 before 10.6.9 CU1; from 10.6.0 before 10.6.0 CU7; from 10.5.0 before 10.5.0 CU19; from 10.4.0 before 10.4.0 CU22.Source: cve.now feed data
Am I affected, and how do I check?
DataMiner versions before the fixed builds are affected: 10.6.9 before 10.6.9 CU1, 10.6.0 before 10.6.0 CU7, 10.5.0 before 10.5.0 CU19, and 10.4.0 before 10.4.0 CU22. To check a system, look up the DataMiner version and compare it against these builds.Source: vulncheck.com
How do I fix CVE-2026-89017?
Upgrade to the fixed build for your release line: 10.6.9 CU1, 10.6.0 CU7, 10.5.0 CU19, or 10.4.0 CU22.Source: vulncheck.com