Skip to main content
← Vulnerabilities

GeoNode: OS command injection via uploaded file layer name

GeoNode versions before 5.1.0 are affected when a vector file is uploaded with a crafted layer name. The fix is in 5.1.0. CVSS rates it 8.8 (high), and no vendor severity is given.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.8HighCNA
Exploited
No known exploitation
Fix
Fixed in 5.1.0
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. A vector file is uploaded with a crafted layer name

Published
Last modified
27/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

GeoNode, a geospatial content management system for managing and publishing geospatial data, is affected by an OS command injection flaw triggered by a crafted layer name in an uploaded vector file. A remote attacker with low-privileged login can exploit this over the network to run arbitrary operating-system commands on the GeoNode server.

Read the original description

GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. Prior to 5.1.0, a crafted vector file layer name supplied during upload allows a low-privileged remote user to inject shell syntax and execute arbitrary operating-system commands on the GeoNode server. This issue is fixed in version 5.1.0.

cve.now Index

27Pcve.now Index 27 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach10/20Affects PyPI packages
  • Severity8.8/10CVSS 8.8
  • No patch0/5No signal

What would change the score

  • Would score about 77 if added to CISA KEV
  • Would score about 72 if CISA's SSVC rates exploitation active
  • Would score about 34 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    A vector file is uploaded with a crafted layer name
  • Upgrade to a fixed version: 5.1.0.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • GeoNode geonode

    fixed in 5.1.0

  • geonodePyPI

    fixed in 5.1.0

Evidence 3

  1. Advisory
  2. Repository
  3. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-33050

Is CVE-2026-33050 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Uploading a vector file with a crafted layer name can cause GeoNode to run arbitrary operating-system commands on the server.Source: github.com, github.com

Which versions are affected by CVE-2026-33050?

geonode: before 5.1.0. geonode (PyPI): before 5.1.0.Source: cve.now feed data

Am I affected, and how do I check?

The affected range runs from the first release up to but not including 5.1.0. To check a installation, look at the GeoNode version it reports and compare it with 5.1.0.Source: github.com, github.com

How do I fix CVE-2026-33050?

Upgrade GeoNode to 5.1.0, which contains the fix. No workaround is listed in the facts.Source: github.com, github.com