Fraunhofer HHI VVdeC before 3.2.1 Out-of-Bounds Read via Slice::getRefPic
- Exploited
- No known exploitation
- Fix
- Fixed in 3.2.1
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 3.2.1.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 7/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Fraunhofer HHI VVdeC video decoder, before version 3.2.1, has an out-of-bounds read flaw that lets an attacker crash the decoder. A local attacker with no login needed can trigger it by supplying a bitstream with overlapping slice coverage, but it also requires a user to take an action, such as opening the file.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
Fraunhofer HHI VVdeC before 3.2.1 contains an out-of-bounds read vulnerability that allows attackers to crash the decoder by supplying bitstreams with overlapping slice CTU coverage. Attackers can code a CTU in a second slice so a bi-predicted BDOF coding unit carries a negative reference index, causing Slice::getRefPic to read outside m_apcRefPicList and crash decoding.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure?/25Unknown. No advisory context yet
- Reach?/20Unknown. No tracked technology or package matched
- Severity6.9/10CVSS 6.9
- No patch0/5No signal
What would change the score
- Would score about 62 if added to CISA KEV
- Would score about 57 if CISA's SSVC rates exploitation active
- Would score about 29 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 3.2.1.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- fraunhoferhhi vvdec
fixed in 3.2.1
Evidence 7
- Patch
- Patch
- Report
- Repository
- Repository
Show all 7 sourcesShow fewer sources
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-124310
Is CVE-2026-124310 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-124310?
vvdec: before 3.2.1.Source: cve.now feed data
How do I fix CVE-2026-124310?
Upgrade to a fixed version: 3.2.1.Source: cve.now feed data