Fraunhofer HHI VVdeC before 3.2.1 Heap Out-of-Bounds Read via SEIReader::xParseSEIScalableNesting
- Exploited
- No known exploitation
- Fix
- Fixed in 3.2.1
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 3.2.1.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 7/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Fraunhofer HHI's VVdeC decoder library, before version 3.2.1, has a heap out-of-bounds read flaw that lets an attacker crash the decoder or copy nearby heap memory. It is reached locally, without logging in, but the victim must open a crafted VVC bitstream.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
Fraunhofer HHI VVdeC before 3.2.1 contains a heap out-of-bounds read vulnerability in SEIReader::xParseSEIScalableNesting that allows attackers to read past heap allocations by casting the SEI wrapper object instead of its payload. Attackers can supply a crafted VVC bitstream with a scalable nesting SEI containing a nested buffering period SEI to crash the decoder or copy adjacent heap memory.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure?/25Unknown. No advisory context yet
- Reach?/20Unknown. No tracked technology or package matched
- Severity6.9/10CVSS 6.9
- No patch0/5No signal
What would change the score
- Would score about 62 if added to CISA KEV
- Would score about 57 if CISA's SSVC rates exploitation active
- Would score about 29 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 3.2.1.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- fraunhoferhhi vvdec
fixed in 3.2.1
Evidence 6
- Patch
- Report
- Repository
- Repository
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-124309
Is CVE-2026-124309 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-124309?
vvdec: before 3.2.1.Source: cve.now feed data
How do I fix CVE-2026-124309?
Upgrade to a fixed version: 3.2.1.Source: cve.now feed data