Skip to main content
← Vulnerabilities

ESEngine DeepSeek-Reasonix Build Script Execution build.rs loadGitStatus permission

5.3MediumCNA
Exploited
No known exploitation
Fix
Fix or patch referenced
Who is exposed
Not reported

Do first: Apply the patch listed under Evidence.

Published
Last modified
12/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

ESEngine DeepSeek-Reasonix contains a permissions flaw in the loadGitStatus function of its build.rs Build Script Execution component. An attacker can reach it remotely without logging in, but it requires a user to take an action.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

A vulnerability was found in ESEngine DeepSeek-Reasonix up to 1.33.0. Impacted is the function loadGitStatus of the file build.rs of the component Build Script Execution. Performing a manipulation results in permission issues. The attack may be initiated remotely. Upgrading to version 1.34.0 is recommended to address this issue. The patch is named a54659c2c5b0f4e57aae2b44d41f421c6a71e8cf. You should upgrade the affected component.

cve.now Index

12Pcve.now Index 12 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure7/25Reachable over the network without a login · Unknown: No advisory context yet
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity5.3/10CVSS 5.3
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 27 if advisories confirm default setups are exposed

What to do

  • Apply the patch listed under Evidence.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • ESEngine DeepSeek-Reasonix

    1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7, 1.8, 1.9, 1.10, 1.11, 1.12, 1.13, 1.14, 1.15, 1.16, 1.17, 1.18, 1.19, 1.20, 1.21, 1.22, 1.23, 1.24, 1.25, 1.26, 1.27, 1.28, 1.29, and 4 more

Evidence 9

  1. Advisory
  2. Advisory
  3. Advisory
  4. Advisory
  5. Advisory
Show all 9 sourcesShow fewer sources
  1. Patch
  2. Patch
  3. Patch
  4. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123989

Is CVE-2026-123989 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-123989?

DeepSeek-Reasonix: versions 1.0, 1.1, 1.2, 1.3, 1.4 and 29 more.Source: cve.now feed data