Skip to main content
← Vulnerabilities

Babelfish for PostgreSQL Privilege Escalation

Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8 and 5.1-5.4 are affected. The fix is in 4.10, 5.6 and 6.1.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.8HighCNA
Exploited
No known exploitation
Fix
Fixed in 4.10, 5.6, 6.1
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 are affected

18Pcve.now Index 18 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity9.8/10CVSS 8.8, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 25 if CISA's SSVC rates it automatable

CVE-2026-119922 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects babelfish-for-postgresql; fixed in 4.10, 5.6 and 6.1.

Published
Last modified
Published
Not listed in CISA KEV
18/100 · provisional
Specific setups only
Fix
Fixed in 4.10, 5.6, 6.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Babelfish for PostgreSQL, an extension that lets PostgreSQL accept Microsoft SQL Server-style connections, contains an access control flaw that allows an authenticated remote user to gain higher privileges than they should have. This could let an attacker with a valid low-level account perform actions reserved for more privileged users.

Read the original description

Improper access control in the Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 may allow remote authenticated users to elevate their privileges. To remediate this issue, we recommend you upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later.

What to do

  • Check whether your setup matches what the bug needs.

    Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 are affected
  • Upgrade to a fixed version: 4.10, 5.6, 6.1.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • AWS babelfish-for-postgresql

    From 1.2 · through 1.5; From 2.1 · through 2.15; From 3.1 · through 3.12; From 4.0 · through 4.8; From 5.1 · through 5.4

Evidence 4

  1. Advisory
  2. Advisory
  3. Patch
  4. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-119922

Is CVE-2026-119922 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaw may allow remote users who are already authenticated to elevate their privileges beyond what they should have.Source: aws.amazon.com

Which versions are affected by CVE-2026-119922?

babelfish-for-postgresql: from 1.2 through 1.5; from 2.1 through 2.15; from 3.1 through 3.12; from 4.0 through 4.8; from 5.1 through 5.4.Source: cve.now feed data

Am I affected, and how do I check?

Babelfish for PostgreSQL extension versions 1.2 through 1.5, 2.1 through 2.15, 3.1 through 3.12, 4.0 through 4.8, and 5.1 through 5.4 are listed as affected. Check the installed Babelfish for PostgreSQL extension version and compare it with these ranges.Source: aws.amazon.com

How do I fix CVE-2026-119922?

Upgrade to 4.10, 5.6 or 6.1, whichever matches the release line in use. No workaround is listed in the source.Source: aws.amazon.com