Vulnerability-Lookup: memory amplification through webhook payload template format specifiers
- Exploited
- No known exploitation
- Fix
- Fixed in 6.4.1
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 6.4.1.
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.29% · 22nd percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 8/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Vulnerability-Lookup, a vulnerability tracking application, can be made to use excessive memory through the payload template of its webhook notifications. A signed-in user can reach this remotely, and the default setup lets anyone with a confirmed account create one, so an attacker could exhaust server memory and cause a denial of service.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
In Vulnerability-Lookup 5.5.1 up to but not including 6.4.1, a signed-in user could make the server allocate memory far out of proportion to their input through a webhook notification's payload template. Each placeholder's format specifier was passed unchanged to Python's string formatting, which builds the padded result before its size can be checked. A template of a few dozen bytes, such as {"text": "{title:>999999999}"}, therefore produced a string of about 1 GB when the notification form test-rendered it on save, and repeating such fields multiplied the cost. Templates that passed the save check could also repeat placeholders such as {text} thousands of times; the notification daemon rebuilt those on every webhook delivery. Deeply nested templates raised an unhandled recursion error (HTTP 500). An attacker needs only an account, which the default configuration lets anyone create after e-mail confirmation. They could exhaust the memory of web workers or the notification daemon, causing a denial of service. Version 6.4.1 caps every number in a format specifier at 256, limits a rendered template to 1,000,000 characters both on save and at delivery, and rejects templates nested deeper than 32 levels.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure3/25Reachable over the network · Unknown: No advisory context yet
- Reach?/20Unknown. No tracked technology or package matched
- Severity5.3/10CVSS 5.3
- No patch0/5No signal
What would change the score
- Would score about 63 if added to CISA KEV
- Would score about 58 if CISA's SSVC rates exploitation active
- Would score about 27 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 6.4.1.
Timeline
- CVE published
- Record last updated
- First seen by cve.now
Affected versions
- vulnerability-lookup vulnerability-lookup
From 5.5.1 · fixed in 6.4.1
Evidence 1
- Patch
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-123660
Is CVE-2026-123660 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-123660?
vulnerability-lookup: from 5.5.1 before 6.4.1.Source: cve.now feed data
How do I fix CVE-2026-123660?
Upgrade to a fixed version: 6.4.1.Source: cve.now feed data