Skip to main content
← Vulnerabilities

Apache James: Denial of service upon MIME parsing

8.7HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.9.1
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 3.9.1.

Published
Last modified
36/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

Allocation of Resources Without Limits or Throttling in Apache James Mime4J library prior version 0.8.15 allows Denial of Service upon parsing Mime messages. Users are recommended to upgrade to Apache James server 3.9.1 that relies on fixed MIME4J 0.8.15 which addresses the issue.

See CVE-2026-85108 in Apache James MIME4J library.

cve.now Index

36Pcve.now Index 36 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed per the CVSS vector, reachable over the network without a login · Unknown: No advisory context yet
  • Reach10/20Affects Maven packages
  • Severity8.7/10CVSS 8.7
  • No patch0/5No signal

What would change the score

  • Would score about 81 if added to CISA KEV
  • Would score about 76 if CISA's SSVC rates exploitation active
  • Would score about 41 if advisories confirm default setups are exposed

Impact

  • Widely used

    1 packages depend on org.apache.james:james-server.Source: deps.dev

What to do

  • Upgrade to a fixed version: 3.9.1.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Apache Software Foundation Apache James

    fixed in 3.9.1

  • org.apache.james:james-serverMaven

    fixed in 3.9.1

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-85111

Is CVE-2026-85111 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-85111?

Apache James: before 3.9.1. org.apache.james:james-server (Maven): before 3.9.1.Source: cve.now feed data

How do I fix CVE-2026-85111?

Upgrade to a fixed version: 3.9.1.Source: cve.now feed data